Forum Replies Created

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • in reply to: Smart Series API how to get access token ? #56073
     arikadiusz says:

    arikadiusz
    Participant

    Hi,

    So I am trying to get my head around this. Do I understand correctly that to do anything with this API I need to first authenticate aka get access token ?
    If so how do I fill this example from their website to return access token ?

    https://lwtokens.docs.apiary.io/#reference/0/request-an-access-token-using-a-refresh-token/request-an-access-token-using-a-refresh-token?console=1

    + header:
    authorization: “basic TOKEN”
    + body:
    {
    grant_type: “refresh_token”,
    refresh_token: “REFRESH_TOKEN”
    }

    I have tried replacing TOKEN, REFRESH_TOKEN, refresh_token in different combinations (very frustrating how badly this is documented…)

    this is what I am keep getting in response :

    {
    “error”: “invalid_request”,
    “error_description”: “Missing grant type”
    }

    I have Bearer and Refresh Token from Linkplus Client site. What next ? please advise.

    A

    in reply to: Magnetic contact switch – intelligent? #16975
     arikadiusz says:

    arikadiusz
    Participant

    In my opinion it’s not great that this thing sends OFF command.

    Let’s use simple example : House – main entrance. You open the door lights switch ON. Fine, all groovy. Now,
    cuz it’s freezing outside you CLOSE the door. And guess what ? all your Hallway lights (or whatever else) goes OFF.
    Upsss ! deisign failure! Should it have some switch to turn OFF sending OFF command ?

    Cheers!

    in reply to: 2.91C has broken UDP communication AGAIN! #16583
     arikadiusz says:

    arikadiusz
    Participant

    It’s funny how easy you can lost customers. As AV integrator for some time I really thought your products are
    best I can get with wireless lightning on the UKs market at the moment. I had hundreds of problems with Rako
    products and LightwaveRF seemed to be working fine. But for some reason this year you have decided to sr***
    every one. Seriously what kind of Programmers work on firmware releases ? Guy should be taken out
    of the equation. We need something that works ! no bloody firmware updates which you can’t switch off.
    You do realize your biggest market are guys like myself who use your products just to integrate with them ?
    I don’t care about your doggy iPhone or iPad app – total waste of time and energy, slow and unreliable. I just want something
    that will continue to work as 3rd party device, why ? cuz I fu** paid for it !!

    Regards.

    in reply to: Link no longer responding to UDP commands – any advice #15855
     arikadiusz says:

    arikadiusz
    Participant

    Hi all,

    I am using it with Crestron. I have fixed it Wednesday (17.Sep.2014) by adding “100″ in front of every command.
    All you have to send is “100,!R1D1F1\x0D” and it works fine. No need to reregister or change anything else.

    Cheers,
    A.

    in reply to: VPN issue with Lightwaverf app #12979
     arikadiusz says:

    arikadiusz
    Participant

    Lightwave rf app doesnt recognize when you are using
    VPN on android phone. VPN would make it work faster
    than the way its currently implemented (through http server or
    something). People with proper routers should be able
    To use it. Any chance for this bug to be fixed please?

    Thanks
    A.

Viewing 5 posts - 1 through 5 (of 5 total)