New iOS App – Now Available!

LightwaveRF Communi… > Forum > General LightwaveRF… > New iOS App – Now… > Page 9

LightwaveRF Community: Welcome Forums General LightwaveRF Discussion New iOS App – Now Available!

This topic contains 133 replies, has 36 voices, and was last updated by  grant 5 years, 5 months ago.

Viewing 14 posts - 121 through 134 (of 134 total)
  • Author
    Posts
  • #10535
     rhlangdon says:

    rhlangdon
    Participant

    I had to do that with an earlier upgrade.

    Currently, even though I set up a completely clean installation and a new account so all was wiped and became brand new, I have a saving issue. I am running the beta version on my iPhone and the released app on my iPad. When I save, either way, and download to the other, 4 devices disappear and two timers do not display the device name, only “Device” (one of the missing devices). Whilst they do not display I know they exist as if I add them to the missing unit they are already paired and in Timers the device name properly appears.

    LighwaveRF are looking at this. It will be interesting to know if any other users have found the saving function does not seem to save everything properly.

    #10546
     ScubyD says:

    ScubyD
    Participant

    I cleared the memory of all of my LWRF devices a couple of days ago, as I’ve moved to a slightly different way of controlling them. Sadly, only tonight discovered that the new iOS app is absolutely abysmal. Full of bugs when editing rooms / devices – often wouldn’t let me edit anything, the “add” button in edit mode never worked, occasionally wouldn’t transmit anything either normally or to pair… killing it and restarting usually fixed it, but when I was trying to re-pair a whole house worth of stuff it was a truly painful process.

    A really sad reflection of how amateurish some aspects of Lightwave are.

    #10612
     jonesy says:

    jonesy
    Participant

    Hi All,

    In the old App I had issues with room 7 (it interfered with timers etc), I found the solution was to only use some of the slots in that room (slot 1 didn’t work). This evening I was going to rearrange my rooms etc, (as I now have more devices) in the new app.

    Does anyone know if there are still issues with room 7?

    If there are issues with room 7 does anyone have a work around in the new app?

    Cheers.

    #10828
     rhlangdon says:

    rhlangdon
    Participant

    An update on my position to say I have no issues with the current app. I am running the beta version on my iPhone and the released version on my iPad. All is functioning as it should now. I have stability. Or have I spoken too soon? I hope not! I even have two rooms set up to add heating controls to when they eventually arrive!

    Richard.

    #11087
     madengineer says:

    madengineer
    Participant

    Hi guys,

    I had a discussion over here about current issues in the iPhone app. This looks like a better home for the discussion.

    I don’t have any problems saving/downloading settings, but I found the following issues. Your mileage may vary:

    The bugs I’ve found so far in v1.1.2 on an iPhone 4, iOS 5.1.1, are:
    1) The app crashes if you try to register using it. The only way I could get into the app was to register on the web site and log in.
    2) The process of renaming rooms is buggy. If you press Edit on the “your home” page and tap on the text box containing a room name to edit it, it dissapears from the editing screen! If you come out of editing mode, that room has then been renamed. I go from having a kitchen and a living room to having a kitchen and a kitchen1.
    3) Setting the brightness level for devices when editing/creating an event is very tricky. I line up the slider precisely on, say, 20%, and it jumps to a random value anywhere from 15-25%.

    I’m not saying the app doesn’t work for anyone, but with the hardware I have (iPhone 4, iOS 5.1.1) these issues are very much apparent and there is no shortage of comments about issues in the app store reviews. I just tried it on an iPad (iOS 6.1.2) and the registration step worked fine. However, even after reinstalling the app on my iPhone it is still clearly displays issue 1) by crashing if I try to register a new account on it. Perhaps the app is doing something that isn’t supported on older hardware/iOS versions? What iPhone version are you using? I don’t see any clear indication on the app store that only newer hardware/software is supported so I’d expect it to work properly on any iOS version.

    2) is in part an issue of UI design – when you tap to edit a room on the iPhone 4, the keyboard appears and scrolls the room you’ve just tapped on up off the screen. This happens on my iPad as well (same screen aspect ratio?) Maybe you don’t see this on an iPhone 5 with a taller screen… In both cases the room you tap on moves up off the top of the screen, leaving the room below it at the top position. Only my iPhone4 has the issue of the room name being corrupted, and only in specific cases. For example, with 3 rooms, I tap on the middle one, kitchen, which then shoots off the top of the screen. I then tap done, and the room above it is corrupted – living room turns into kitchen1! It does this every time, so it’s a reproducible bug.

    3) Call it finger trouble but I stand by this – as you release your finger from the slider it jumps to one side or the other. I’d expect it to keep the last number displayed in the marker above the slider.

    It’s still much nicer to use than the iPhone old app, just a shame there are still these issues – if they affect you it gives a very bad impression and the work arounds aren’t intuitive (I only discovered the my-lightwave web site by accident, so was very nearly stuck with the app crashing at the sign up screen.) I’m happy to support the developers in providing information that helps track the bugs down. After all, I’d like to get the full potential out of the hardware I’ve paid for.

    Cheers,
    Richard.

    #11088
     madengineer says:

    madengineer
    Participant

    Apparently links don’t work in the forum?
    here = http://lightwaverfcommunity.org.uk/forums/topic/timers-not-working/#post-11058

    #11091
     rhlangdon says:

    rhlangdon
    Participant

    Madengineer

    I do not have the problems you describe but it may be the IOS version you are using. I am using an iPhone with IOS version 7.0 and an iPad with IOS version 7.0 On the iPhone the app is a beta version and on the iPad the latest release. All runs smoothly (but see later). I have edited names, deleted, re-input devices etc., saved, downloaded and have no problems other than one.

    The one issue is that when I edit and save the WiFi link picks up the Timers but postpones the start time by 24 hours. Not in every case. Thus when you first wrote in I started to mess around to see if I could recreate your problem. This was at 09:30. I found that one or two timers set to start at dusk or in the evening had their start date put forward by one day. I understand this issue is being addressed by LightwaveRF in a software release for the WifFi Link to come shortly.

    My only thoughts for your problem are that you have a buggy file saved and when you change things, or edit, the bugs in the saved file are still there in the background. My best suggestion is start from scratch. If you deleted everything on your phone and then added back the devices there must be a chance deep in the programming of the file you have there remains these problems. You need a clean new file. If you can do it I would:

    1. Delete the whole app from your phone.
    2. Do a hard re-set on your phone.
    3. Download the latest version of the app from the Apple Store.
    4. Start a new account in settings in the app on your phone.
    5. Input all the rooms and devices you want to have.
    6. Save the file.
    7. Go to every switch, plug-in or what ever you have and reset them to wipe them of all memory of previous pairings.
    8. Go around with your phone pairing afresh with each device or switch.
    9. Save the file to the web.
    10. Sync with the WiFiLink.
    11. Exit the app completely on the phone then open it again.

    As said I am not having these problems and all runs smoothly. It may be a corrupt file you have it may be of course the version of the IOS you are running but I doubt that. When I get a beta version update it indicates it is for IOS 5.1 and above. It does sound like corruption in your file and the solution is more or less the above. It does not take as long as it may seem! I have done it in the past.

    Richard.

    #11098
     bernardh says:

    bernardh
    Participant

    I had been through all of the delete, reset, re-pair, new account processes and yet I was getting real problems with timers not firing or firing randomly.

    I finally got to the point of being able to speak to JSJS support whilst in front of my wifi link yesterday. They had to fix the registration: in the (new) app settings screen the MAC address was x’s.

    After they did their bit, I then had to download setting from web to the phone again. At that point I could see the proper MAC address. After the wifi link had finished working through settings load (the screen was cycling through the timers etc) I was then able to check in System>Status (on the wifi link) that the number of Timers on the app matched the count (T) on the wifi link. (There’s another letter for the events, but it’s the initial of whatever they used to be called.)

    This was all after dusk – and all my timers are related to dusk – so fingers crossed they will work tonight. (Incidentally, the timer start dates were all still stepped forward by a day which is apparently to stop them firing immediately, but it seems unhelpful and counterintuitive to me so I agree with the apparent decision to change this behaviour.)

    Unless someone else here knows how to do the registration part I describe, it may be necessary to call support.

    I will post back this evening with an update.

    Bernard

    #11099
     markk says:

    markk
    Participant

    I notice there has been an update released today. I can’t download it as my work network won’t allow it. Hopefully will solve issues people on here have raised though.

    Running RFXCom with Domoticz on raspberry pi3. LWRF dimmer switches, PIRs and plug sockets. Some Homeeasy switches, harmony hub controlling AV and air con. Geofencing with Pilot app. Tado for heating and cooling.
    #11107
     Bobby Dazzler says:

    Bobby Dazzler
    Participant

    There’s a splash screen which appears now on the ‘old’ app, asking you to download the ‘new’ app which seems a little premature if the new app is still buggy.

    #11108
     bernardh says:

    bernardh
    Participant

    Further to my earlier post, all my timers fired correctly this evening.

    #11868
     Bobby Dazzler says:

    Bobby Dazzler
    Participant

    Is the new app stable now? Any known bugs or issues remaining?

    #11884
     h3mp says:

    h3mp
    Participant

    I have no issues currently :-)

    #11887
     grant says:

    grant
    Participant

    I would think there will be an update to the app soon (before march) so that the heating controls are enabled.

Viewing 14 posts - 121 through 134 (of 134 total)

You must be logged in to reply to this topic.

ABOUT Chris

Chris works as a techie for a large IT service provider. He is a geek at heart and loves nothing more than trying to automate his home. The problem is, his wife simply doesn't get it and can't understand why they can't have 'normal' lights like everyone else! Chris is dedicated therefore to implementing automation in a family friendly way.

View all posts by