2 gang dimmer not operating with dimmmable LED's

LightwaveRF Communi… > Forum > Forum Support > 2 gang dimmer not…

LightwaveRF Community: Welcome Forums Forum Support 2 gang dimmer not operating with dimmmable LED's

This topic contains 2 replies, has 2 voices, and was last updated by  Westy 3 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #19093
     Westy says:

    Westy
    Participant

    Hi, brand new to this forum but I can see from some previous reading that I’m likely to repeat a common gripe. But I’m running out of ideas now, so looking for something else to try next.

    I’ve built a garden room and like the idea of being able to control the electrics from the house, especially the lights. So I have installed lightwave sockets all round and a two gang dimmer. I have 5 lights on each gang. Initially I made the mistake of not checking the bulbs that came with the lights – which weren’t dimmable. My electrician still insisted it was a fault with the switch, so Maplin replaced that for me.

    So now, I’ve fitted a brand new switch and got the Lumilife GU10 4 watt dimmable bulbs (compatible with Lightwave according to what I read here). Some progress, in as much as the lights come on. One (the closest to the dimmer) flickers terribly. One barely comes on (other tests suggest that one bulb is suspect). When you switch the lights off via the switch, they all stay on (very dim). On top of that, the dimming range seems to be 2 stage. Full power or half power. I’ve replaced the bulbs with the original mini sun (non dimmables) and my 2 quid plastic switch. I don’t know what to try next ? Can anyone help?

    #19094
     Node Zero says:

    Node Zero
    Participant

    Sounds like you have a 400 series switch which don’t behave with Ledhut lamps, it will probably be ok with Megaman lamps, or if you can get your hands on a 200 series switch then your lamps should be ok.

    Or, I read on here awhile back that there is a configuration procedure with the 400 series switches that you might be able to try although don’t quote me on that.
    HTH.

    #19095
     Westy says:

    Westy
    Participant

    Thanks for the reply. I’m not sure what series the dimmer is. The original one that I returned I bought in February but only just fitted it. I’ll check with Maplin and see what model the new one is they replaced it with.

    I’ll return the bulbs to LED hut and try the megaman equivalents and see how that goes.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.